No Image

Если или в excel много условий

СОДЕРЖАНИЕ
11 просмотров
29 июля 2019

Функция ЕСЛИ одна из самых популярных и часто используемых функций Excel. Используя ее совместно с операторами сравнения и другими логическими функциями Excel, можно решать достаточно сложные задачи. В этом уроке мы попробуем разобрать ее действие на простых примерах, а также научимся использовать сразу несколько функций ЕСЛИ в одной формуле.

Коротко о синтаксисе

Функция ЕСЛИ имеет всего три аргумента:

=ЕСЛИ(заданное_условие; значение_если_ИСТИНА; значение_если_ЛОЖЬ)

Первый аргумент – это условие, благодаря которому формула может принимать решения. Условие проверяется в самую первую очередь и способно вернуть всего два значения – ИСТИНА или ЛОЖЬ. Если условие истинно, то формула вернет второй аргумент, в противном случае третий.

Пример 1

Обратимся к примеру, приведенному на рисунках ниже. В данном примере функция ЕСЛИ в первую очередь проверят условие A1>25. Если это так, то формула возвратит текстовую строку “больше 25”, в любом другом случае – “меньше или равно 25”.

Пример 2

Функция ЕСЛИ является очень гибкой и ее можно применять в различных ситуациях. Рассмотрим еще один пример. В таблице ниже приведены результаты переаттестации сотрудников фирмы:

В столбец C нам необходимо выставить результат экзамена, который должен содержать всего два варианта: Сдал или Не сдал. Те, кто набрал более 45 баллов – сдали экзамен, остальные нет.

  1. Выделите ячейку, в которую необходимо ввести формулу. В нашем случае это ячейка C3.
  2. Введите в нее выражение: =ЕСЛИ(B3>45; “Сдал”; “Не сдал”) и нажмите Enter.
  3. Данная формула сравнивает значение в ячейке B3 с числом 45, если значение больше 45, то возвращает строку “Сдал”, иначе “Не сдал”.
  4. Скопировав формулу в остальные ячейки таблицы, можно увидеть, что 2 человека из 5 не прошли переаттестацию.

Функция ЕСЛИ и несколько условий

Функции ЕСЛИ можно вкладывать друг в друга, если необходимо расширить варианты принятия решений в Excel. Например, для рассмотренного ранее случая переаттестации сотрудников, требуется проставить не результат, а оценку из ряда: Отлично, Хорошо и Плохо. Оценка Отлично ставится при количестве баллов более 60, оценка Хорошо при более 45 и оценка Плохо в остальных случаях.

    Чтобы решить эту задачу, введем в ячейку C3 следующую формулу:=ЕСЛИ(B3>60;”Отлично”;ЕСЛИ(B2>45;”Хорошо”;”Плохо”)) и нажмем Enter.

  • Данная формула обрабатывает сразу два условия. Сначала проверяется первое условие: B3>60. Если оно истинно, то формула возвращает значение “Отлично”, а остальные условия не обрабатываются. Если первое условие ложно, то функция ЕСЛИ переходит ко второму: B2>45. Если второе условие истинно, то формула возвращает значение “Хорошо”, а если ложно, то “Плохо”.
  • Скопировав формулу в остальные ячейки таблицы, можно увидеть, что на отлично сдал один человек, а на оценки хорошо и плохо по два человека.
  • Читайте также:  Резкий запах стула у грудничка

    Как видите, вместо второго и третьего аргументов функции ЕСЛИ можно подставлять новые функции ЕСЛИ, тем самым расширяя число условий, которое формула может обработать. Таким образом, Вы можете создать нужное количество вложений. Правда есть очевидный недостаток такой конструкции, после 3-5 вложений формула станет нечитаемой и громоздкой, и с ней будет невозможно работать.

    В Excel существуют более благородные инструменты для обработки большого количества условий, например, функция ВПР или ПРОСМОТР.

    Итак, в этом уроке мы рассмотрели логическую функцию ЕСЛИ во всей ее красе и примерах, а также разобрали простой пример с использованием сразу нескольких функций ЕСЛИ в одной формуле. Надеюсь, что эта информация была для Вас полезной. Удачи Вам и больших успехов в изучении Microsoft Excel!

    Блог о программе Microsoft Excel: приемы, хитрости, секреты, трюки

    Функция ЕСЛИ в Excel позволяет оценивать ситуацию с двух точек зрения, например, значение больше 0 или меньше, и в зависимости от ответа на этот вопрос, произведи дальнейшие расчеты по той или иной формуле. Однако, не редки ситуации, когда вам приходится работать более, чем с двумя условиями. В сегодняшней статье мы рассмотрим примеры создания формул в Excel с несколькими условиями ЕСЛИ.

    Прежде, чем начать изучать данный урок, рекомендую прочитать статью про функцию ЕСЛИ, где описаны основные приемы работы.

    Принцип создания формул с несколькими условиями ЕСЛИ заключается в том, что в одном из аргументов формулы (значение_если_ИСТИНА или значение_если_ЛОЖЬ) находится еще одна формула ЕСЛИ.

    Вам также могут быть интересны следующие статьи

    80 комментариев

    Нужно вернуть определенное значение из ячейки и посчитать балл, т.е. например в ячейке D3 может быть значение А, Б, В, Г, надо в ячейку D4 вернуть значение в зависимости от буквы, например А=1, Б=2, В=3 и так далее. Как сделать? Можно ли через формулу ЕСЛИ?

    Статья хорошая, спасибо.
    Но.. вначале статьи планы ставят из минимального расчета 500$, а все дальнейшие расчеты исходят из 400$.
    Как бы надо стараться следовать тем планам, что ставите.

    Данный метод хорош, если у нас немного критериев (2-3), но когда их 10, то в такой формуле потом трудно разобратся «что и откуда». В таком случае можно (и нужно) обойтись без ЕСЛИ.
    Для этого создаем маленькую табличку с нашими критериями: в первой строке по возрастанию заполняем критерии (в приведенном примере это будут 0, 500, 750, 1000); во второй строчке под каждым критерием заполняем соответствующий процент (7, 10, 12,5, 16). Допустим, в диапазоне A1:D1 у нас заполнены критерии, а в диапазоне A2:D2 — соответствующие проценты. В ячейке А5 имеем цифру продаж; для рассчета комиссии используем следующую формулу: =A5*ИНДЕКС($A$2:$D$2;ПОИСКПОЗ(A5;$A$1:$D$1;1)).
    ПОИСКПОЗ ищет расположение критерия, который меньше продаж, но наибольший в списке, а ИНДЕКС по полученному номеру выдает нам необходимый процент.

    Читайте также:  Ацетонемическое состояние мкб 10

    Примечание: Мы стараемся как можно оперативнее обеспечивать вас актуальными справочными материалами на вашем языке. Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Просим вас уделить пару секунд и сообщить, помогла ли она вам, с помощью кнопок внизу страницы. Для удобства также приводим ссылку на оригинал (на английском языке).

    Функция ЕСЛИ позволяет выполнять логические сравнения значений и ожидаемых результатов. Она проверяет условие и в зависимости от его истинности возвращает результат.

    =ЕСЛИ(это истинно, то сделать это, в противном случае сделать что-то еще)

    Но что делать, если необходимо протестировать несколько условий, где все условия должны иметь значение истина или ложь ( и) или только одно условие должно иметь значение истина или ложь ( или), или если нужно проверить, не соответствует ли условие условиям? Все три функции можно использовать самостоятельно, но они гораздо более распространены с помощью функций если.

    Используйте функцию ЕСЛИ вместе с функциями И, ИЛИ и НЕ, чтобы оценивать несколько условий.

    ЕСЛИ(И()): ЕСЛИ(И(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

    ЕСЛИ(ИЛИ()): ЕСЛИ(ИЛИ(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

    ЕСЛИ(НЕ()): ЕСЛИ(НЕ(лог_выражение1), значение_если_истина; [значение_если_ложь]))

    Условие, которое нужно проверить.

    Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

    Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

    Здесь приведены сведения о том, как структурировать и( или ) функцию по отдельности. При объединении каждого из них с помощью оператора если они читаются следующим образом:

    И: =ЕСЛИ(И(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

    ИЛИ: =ЕСЛИ(ИЛИ(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

    НЕ: =ЕСЛИ(НЕ(условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

    Примеры

    Ниже приведены примеры некоторых распространенных вложенных операторов IF (и ()), если (или ()) и IF (NOT ()). Функции AND и или или OR могут поддерживать до 255 отдельных условий, но не рекомендуется использовать больше, чем многие из них, поскольку сложные, вложенные формулы могут очень сложно создавать, тестировать и поддерживать. Функция NOT принимает только одно условие.

    Читайте также:  Кишечная палочка е coli лечение

    Ниже приведены формулы с расшифровкой их логики.

    =ЕСЛИ(И(A2>0;B2 0;B4 50);ИСТИНА;ЛОЖЬ)

    Если A6 (25) не превышает 50, возвращается значение TRUE, в противном случае возвращается значение ложь. В этом случае 25 не превышает 50, поэтому формула возвращает значение истина.

    Если значение A7 ("синий") НЕ равно "красный", возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ.

    Обратите внимание, что после ввода условий для всех примеров закрываются закрывающие скобки. Остальные аргументы true/false затем остаются частью внешнего оператора если. Можно также подставить текст или числовые значения для значений TRUE/FALSE, возвращаемые в примерах.

    Вот несколько примеров использования операторов И, ИЛИ и НЕ для оценки дат.

    Ниже приведены формулы с расшифровкой их логики.

    Если ячейка A2 больше B2, возвращает значение истина, в противном случае возвращает значение ложь. 03/12/14 больше 01/01/14, поэтому формула возвращает значение истина.

    =ЕСЛИ(И(A3>B2;A3 B2;A4 B2);ИСТИНА;ЛОЖЬ)

    Если A5 не больше B2, возвращается значение TRUE, в противном случае возвращается значение ложь. В этом случае A5 больше B2, поэтому формула возвращает значение ложь.

    Использование операторов И, ИЛИ и НЕ с условным форматированием

    Вы также можете использовать и, или и не задавать условия условного форматирования с помощью параметра формула. При этом вы можете опустить функцию если и использовать ее и (или) самостоятельно.

    На вкладке Главная нажмите кнопку условное форматирование _гт_ новое правило. Затем установите флажок " использовать формулу для определения ячеек, которые нужно отформатировать", введите формулу и примените выбранный формат.

    "Изменить правило" с параметром "Формула"" xmlns:AntiXSS="urn:AntiXSSExtensions" />

    Вот как будут выглядеть формулы для примеров с датами:

    Если A2 больше B2, отформатировать ячейку, в противном случае не выполнять никаких действий.

    =И(A3>B2;A3 B2;A4 B2)

    Если A5 не больше B2, отформатируйте ячейку, в противном случае не предпринимайте никаких действий. В этом случае A5 больше B2, поэтому результатом будет возвращено значение FALSE. Если вы изменили формулу на = NOT (B2>A5) , она ВОЗВРАТИТ значение true и ячейка будет отформатирована.

    Примечание: Наиболее распространенная ошибка заключается в том, чтобы ввести формулу в условное форматирование без знака равенства (=). Если это сделать, вы увидите, что в диалоговом окне Условное форматирование будет добавляться знак равенства и кавычки в формулу- = "или (A4>B2, A4

    Дополнительные сведения

    Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

    Комментировать
    11 просмотров
    Комментариев нет, будьте первым кто его оставит

    Это интересно
    No Image Проблемы пищеварения
    0 комментариев
    No Image Проблемы пищеварения
    0 комментариев
    No Image Проблемы пищеварения
    0 комментариев
    No Image Проблемы пищеварения
    0 комментариев
    Adblock detector